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1. Introduction 

1.1 Getting Started 
SewCat© is software that allows you to organize your embroidery files into catalogs. These 

catalogs can be either virtual folders (which are stored temporarily in computer memory and later 

saved to disk as a very small database file) or actual directory folders on your hard drive or 

removable media. SewCat allows you to easily view the stitch patterns encoded in your embroidery 

files, making it easy to sort and optionally rename files in meaningful ways.  

 

SewCat gives you the choice of using virtual or real catalogs, depending on your preferences. The 

virtual cataloging that SewCat performs leaves your original embroidery files intact in their original 

locations on the Hard Drive, CD or Removal Drive. This is in contrast to the Explorer cataloging 

option which reorganizes files and folders on your hard drive. There are advantages to each form of 

cataloging.  

 

Virtual Catalog 

In creating virtual catalogs (VC), any mistakes - such as inadvertent file or folder deletions - do not 

permanently affect the original embroidery files (which are never moved or deleted). If you do 

mistakenly delete file(s) or folder(s) in the virtual catalog, they can be restored from the special 

Recycle Bin folder in the VC. When a virtual catalog is saved to a hard drive, it takes up very little 

space. This allows you to create numerous different catalogs containing the same files, while 

occupying (almost) no additional disk space. However, a disadvantage of the virtual catalog 

(compared with a real, or physical catalog) is that only links to the cataloged files are saved. Thus, 

if you change the location of files on your hard drive, or remove the external media (CD or floppy) 

containing the cataloged files, those files will no longer be viewable when you reopen the saved 

catalog file. 

 

Explorer Catalog 

In the Windows Explorer (or real, physical) catalog mode, the catalog folders are created on your 

hard drive and the files you move around (either by copying or moving them with your mouse) are 

actually saved on the hard drive. Thus, although they will occupy additional space on the hard 

drive, there are no virtual links, so you will always be able to view the explorer-style catalog folder 

contents from Windows Explorer.  

 

 

Starting a SewCat Session 

 

To begin a new SewCat catalog, use the directory folder list appearing in the left panel of the 

SewCat workspace to navigate through your directories and locate embroidery files to be displayed 

for cataloging.  
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Storing Files in Virtual Catalog Folders 

 

The catalog appears in the panel on the right of the SewCat workspace. It initially contains a few 

example folders to demonstrate what a catalog might look like. You can delete these folders, or 

rename them to something more suited to your application (see the discussion below on 

manipulating folders for more details). 

  

Use the mouse to select files from the center panel (by left-clicking on the file icons). Once 

selected, drag and drop the icon(s) into the catalog directory tree. Multiple files can be selected by 

holding down the Ctrl or Shift key during selection. An icon will appear with a thickened border 

when it is selected. After it is dropped into the catalog, a box with a check mark will appear below 

the icon to indicate it has been inserted into the catalog. This behavior is modeled after the folder 

selection logic of Windows Explorer®. Note that you can clear the selection status of all files by 

clicking on any blank area in the middle pane. 

 

 

Manipulating Virtual Catalog Folders 

 

To create a new folder in the catalog, first click on the catalog folder that will be the parent of the 

inserted folder. (The new child folder will go below its parent.) Then press the Insert key. This works 

for both top-level folders and subdirectories. New folders can also be added to the Virtual Catalog 

by clicking on the Import Folders item on the Tools menu. This latter method will allow you to insert 

empty folders into the virtual catalog, based on the folders that are selected in the directory view. 

This is an effective way to populate your Virtual Catalog tree. 

 

To delete a folder (and all its contents) or a file from the catalog, first select the folder or file (by 

clicking it) and then press the Delete key. If a file or folder is deleted by mistake, then click the 

Undo toolbar button (or press Ctrl-Z) to recover it. Files and folders in the catalog can also be 

moved to another branch of the catalog (dragged and dropped) or copied (hold down the Ctrl key 

during the mouse drag to copy the selected items to a new location).  

 

An existing catalog folder or file may be renamed by first clicking on the appropriate icon to select 

(highlight) it. Next, click the label (the text next to the icon) to initiate text-editing mode. (This is 

important: simply clicking the file or folder will not put you into editing mode! You must click the text 

label, too.) Once in editing mode a box will appear around the text to be edited, which should now 

be highlighted and blinking. After you complete the text editing, press either Return to accept your 

changes, or Escape to recover the original text. This will exit text-editing mode. 
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To view an enlarged image of any cataloged file, along with some pattern details (stitches, colors, 

size), click on the file icon or label in the catalog. 

 

Selecting the Save As item from the File menu will allow you choose a name and location for 

saving the catalog to a small SewCat catalog file (*scc extension). This file stores the information 

required to restore your virtual catalog in the future. It contains only the names and locations of the 

embroidery files in your catalog and the associated embroidery files on disk. It does not store any 

stitch data.  

 

 

Opening a Catalog File 

 

Another way to begin a SewCat session is by opening an existing embroidery catalog file saved 

from a previous editing session. The last catalog that was edited will automatically load the next 

time SewCat is opened. 

 

 

Interaction of SewCat With Other Applications 

 

You can also drag and drop files from the center panel or directly from the catalog into other 

applications, such as an embroidery editor (for example, SewWhat-Pro) or Windows Explorer. 

 

 

Printing Albums 

 

To print an album of the file icons appearing in the center panel, select Print Album from the File 

menu. 

 

 

Creating a Permanent Catalog: organizing embroidery folders on your hard drive 

 

There may be situations when you want to create permanent catalogs directly on your hard drive 

(in contrast to producing the virtual catalogs described above). SewCat allows you to do this by 

toggling the Catalog/Explorer item on the View menu.  
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1.2 Frequently Asked Questions (FAQ) 
How To ... 

 

•     Alphabetize Files (existing or new) in the Virtual Catalog (VC) 

•     Add a prefix or suffix to selected files in VC 

•     Add a keyword to a single VC file 

•     Add keywords to multiple selected files in VC 

•     Display an Explorer catalog 

•     Display Files for Cataloging 

•     Find the location(s) in the VC of a disk file 

•     Find the location on disk of a file in the VC 

•     Move Files into a Catalog 

•     Rename Files or Folders 

•     Open a previously-saved catalog 

•     Save the present (working) catalog 

•     Delete a folder or file(s) from a catalog 

•     Insert a new folder into a catalog 

•     Show File Details for mid-panel icons 

•     Set search criteria (keywords or pattern-based) 

•     Open a file with an external editor 

 

 

Menus 

 

•    File menu 

•    Edit menu 

•    View menu 

•    Tools menu 

•    Windows menu 
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•    Help menu 

1.3 Contact Us 
If you have any questions about the SewCat program, or any suggestions for improvements or 

additional features you would like to see added, please contact us at 

 

support@sandscomputing.com 

1.4 Purchase SewCat 
 

http://sandscomputing.com/products-shop/ 

 

or some of our reseller websites. Click the SewCat product listing and use the Add-to-Cart button 

to purchase the license. If you want to order a CD, use the down-arrow on the Add-to-Cart button to 

select the CD version of the software. 

 

To update to the latest version of the software, use theINSTALL link (to the right of the Add-to-Cart 

button) for either the 32 and 64-bit version of the product (depending on your Operating System). 

 

There is a 14 day DEMO period during which you may use the software (with no restrictions). After 

that, you can either uninstall the software or purchase a license ( Add-to-Cart ). After purchasing 

the license, the registration information will be emailed to you and you can register the DEMO to 

make it a licensed copy. You DO NOT have to uninstall the DEMO if you want to keep the software, 

but only register it after receiving the license information.  

1.5 Videos 
 

Video tutorials for SewCart can be found and viewed at this location ( videos) on our website. Scroll 

to the "videos" button to open the carousel. 

mailto:support@sandscomputing.com
http://sandscomputing.com/products-shop/
http://sandscomputing.com/products-shop/sewcat-embroidery-cataloguer/#sphVideo
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2. Menus 

2.1 File menu commands 

 

 

The File menu offers the following commands: 

   

New  Creates a new embroidery catalog. 

Open  Opens an existing embroidery catalog. 

Close  Closes an opened embroidery catalog. 

Merge  Merges an existing catalog with the current one. 

Save  Saves an opened embroidery catalog using the previous name. 

Save As  Saves an opened embroidery catalog to a specified file name. 

Print Album  Prints an icon album of the selected directories displayed in the icon panel.  

Print 

Preview  

Displays the document on the screen as it would appear printed. 

Page Setup  Displays a dialog for setting page margins, orientations and icons per page for 

printing. 

Exit  Exits SewCat. 
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2.2 Edit menu command 

 

 

  

The Edit menu offers the following commands: 

 

  

  

Undo 

Reverse previous editing operation 

Delete 

Deletes (prunes) folders or files from catalog tree. 

Insert 

Inserts (grafts) a new, empty folder on catalog tree. 

    

Prune VC   

VC Drive 

Update drive associations for files in the Virtual Catalog 

 

2.3 View menu commands 
   

  

Toolbar  Shows or hides the toolbar. 

Large Toolbar Icons                Toggles between large and small toolbar icon size. 

Status Bar               Shows or hides the status bar. 

Jump Stitches               Shows or hides the display of jump stitches in the lower right 

magnification panel. 
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Texture              Shows or hides texturing (3D view) of the pattern in the lower right 

panel. 

Units               Toggles between American (in) and metric (mm) units in pattern 

properties display. 

Zoom Icons               Magnifies or shrinks the size of icons displayed in the central panel. 

Virtual Catalog-

Explorer  

             Toggles between catalog/Explorer view in right panel. 

Thumbnails               Toggles between normal (display folders and files) and thumbnail 

(display files only) view 

File Information               Displays detailed file and color information in icon view. 

Large Folders               Increases the size of the catalog folder tree items. 

Uncatalogued Files               Displays (if unchecked) or hides embroidery files that appear in the 

present catalog 

Zip files               Displays or hides embroidery files stored in zip files. 

 

2.4 Tools menu commands 

 

 

 The Tools menu offers the following commands: 

   

  

  

Alphabetize                  Alphabetizes files/folder in the catalog. 

hid_zoom.html
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Background Color  Displays popup menu for choosing icon and panel background colors. 

File Filter  Displays a dialog for selecting combinations of file type extensions that will appear in the 

middle icon panel when searching the directory tree. 

Hover Delay  Adjust the hover delay time for customizing the drag/drop response over the catalog folders. 

Also choose an AutoExpand option. 

Icon Layout  Choose the spacing of icons on the screen and the number of icons in a row. 

Import Folders  Import folder tree from directory view (left panel) into virtual catalog. 

Search Criteria  Set criteria to display files with names containing at least on the keywords in the search, or 

satisfying certain pattern-based measures. 

Convert DG Catalog  Convert Designer's Gallery catalog to  SewCat Catalog (*.scc) format. 

Language Support  Displays pop-up menu to select languages supported by SewCat. 
 

 

2.5 Windows menu commands 

 

 

The Window menu offers the following commands, which enable you to arrange multiple views of 

multiple documents in the application window: 

   

Cascade  Arranges windows in an overlapped fashion. 

Tile  Arranges windows in non-overlapped tiles. 
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2.6 Help menu commands 

 

 

The Help menu offers the following commands, which provide you assistance with this application:  

  

  

   

Help Topics  Op         Open an index to help topics and opens "Getting Started" 

Help Manual  D           Displays dialog containing online help manual for SewCat 

    

Auto-Update   To          Toggle (on/off) autoupdate feature for SewCat 

Update Now                Check immediately for available update 
 

  

Restore Defaults  R            Restores registry defaults for SewCat  

About SewCat      D            Displays the version number of this application 

Change Log                Displays information about the history of changes 

 

3. File commands 

3.1 New 
Use this command to create a new Catalog in SewCat. A new catalog is automatically opened 

when you first start a new SewCat session. 
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You can open an existing document with the File Open command. 

 

Shortcuts 

Toolbar:                    

Keys:                     CTRL+N 

3.2 Open 
Use this command to open an existing catalog in a new workspace.   

 

Select the desired catalog from a list of previously-stored SewCat files. Note that the catalog files 

you create with SewCat represent virtual directories. That is, they are stored in small catalog files 

and appear in the SewCat catalog panel, but they do not actually modify the contents of your disk 

directories. Thus, deleting files and folders in the catalog tree has no impact whatsoever on the 

embroidery files you have stored on disk. This makes the virtual cataloging system a very safe and 

user-friendly way of organizing your embroidery files. 

 

You can create new Catalogs with the New command. 

 

Shortcuts 

Toolbar:                    

Keys:                     CTRL+O 

3.3 Close 
Use this command to close all windows containing the active document. SewCat suggests that you 

save changes to your document before you close it.  If you close a document without saving, you 

lose all changes made since the last time you saved it.  Before closing an untitled document, 

SewCat displays the Save As dialog box and suggests that you name and save the document. 

 

You can also close a document by using the Close icon on the SewCat catalog document's 

window, as shown below: 
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Shortcuts 

Keys:              CTRL+F4 closes a document window 

                        ALT+F4 closes the SewCat window or dialog box 

3.4 Merge 
Use this command to merge an existing catalog with the current catalog.   

3.5 Save 
Use this command to save the active document to its current name and directory. When you save a 

document for the first time, SewCat displays the Save As dialog box so you can name your 

document.  If you want to change the name and directory of an existing document before you save 

it, choose the Save As command. 

 

Shortcuts  

Toolbar:                          

Keys:                     CTRL+S 

3.6 Save As 
Use this command to save and name the active Catalog. SewCat displays the Save As dialog box 

so you can name your catalog. SewCat catalog files are given the extension "scc" (SewCat 

Catalog). These files may be double-clicked on your desktop to automatically open SewCat. 

 

To save a catalog with its existing name and directory, use the Save command. 

3.7 Print Album 
Use this command to print an album of SewCat icons based on the icons displayed in the center 

panel. The album icons can be either associated with the directory (left) panel or the virtual catalog 

(right) panel, depending on in which directory tree the last check-boxes were selected. 

 

If there are no files open for viewing, then a summary of the Getting Started topic can be printed by 

selecting Print Manual instead. 

This command presents a Print dialog box, where you may specify the range of pages to be 

printed, the number of copies, the destination printer, and other printer setup options. 
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Shortcuts 

Toolbar:                    
Keys:                     CTRL+P 

3.8 Print Preview 
Use this command to display a preview of the SewCat album as it would appear when printed. 

When you choose this command, the main window will be replaced with a print preview window in 

which one or two pages will be displayed in their printed format. The print preview toolbar offers you 

options to view either one or two pages at a time; move back and forth through the document; 

zoom in and out of pages; and initiate a print job. 

3.9 Page Setup 
Use this File menu item to set characteristics for printing  SewCat album pages. 

 

  

  

Printed Album Layout  

Enter the number of icons per column in the Columns edit box. The number of rows will be 

automatically determined to be consistent with the icon size that results from this choice. 
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Start new page  

You can choose to start a new page for each folder by checking this box. If it is unchecked, multiple 

folders can appear on a single page. 

  

Paper  

Choose the paper size and source. 

  

Orientation  

Choose the page orientation (portrait or landscape). 

  

Margins  

The page margins can be entered here. 

3.10 Exit 
Use this command to end your SewCat session.  You can also use the Close command on the 

application Control menu. SewCat prompts you to save documents with unsaved changes. 

 

Shortcuts 

Mouse:                   Double-click the application's Control menu button. 

                                

Keys:                     ALT+F4 

4. Edit commands 

4.1 Undo 
Use this command (or press the Ctrl-Z key sequence) to undo the previous deletion operation in 

the Virtual Catalog (VC). Alternatively, you may drag/drop files and folders from the (Virtual 

Catalog) Recycle Bin back into the main part of the VC. Files and folders in the VC Recycle Bin will 

be deleted (from the Virtual Catalog, not from the hard drive) when the current session of SewCat 

is closed. A message will pop-up to warn you of their impending deletion. 

 

Undo is also implemented in Explorer mode. Since deleted files and folders are stored in the 

system Recycle Bin, you may also go there at any time to restore them (even after SewCat has 

closed) as an alternative to Undo. 
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Shortcuts 

Toolbar:       

Keys:          Ctrl-Z 

4.2 Delete 
Use this command (or press the Delete key) to remove the currently selected folder or file(s) from 

the catalog. This command is unavailable if there is no item currently selected. 

 

Note that any files or folders deleted from the Virtual Catalog (VC) will appear in the special 

Recycle Bin folder at the bottom of the VC. That way, any files inadvertently deleted can be 

restored by dragging them from the Recycle Bin to any other file in the VC. Files and folders in the 

Recycle Bin are not saved with the other VC files and folders (they are permanently deleted from 

the VC, but the original files on the Hard Drive or other external media are unaffected). 

 

Likewise, in Explorer mode, deleted files and folders are stored in the system Recycle Bin and can 

be restored from there in the case of an unintentional deletion. 

 

 

Shortcuts 

Toolbar:       

Keys:          Delete 

4.3 Insert 
Use this menu command (or press the Insert key) to insert a new folder into the catalog tree below 

the currently selected catalog folder. 

 

Shortcuts 

Toolbar:       

Keys:          Insert 
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4.4 Prune Virtual Catalog 
Use this menu command to remove ("prune") folders from an existing Virtual Catalog. This may be 

useful if a large catalog consists of many different folders that you want to organize into separate 

smaller catalogs for easier access. 

  

For example, support "My Catalog" has the top-level folders shown in Fig 1. 

 

Fig.1 

It might be desirable to split this into two smaller catalogs of Animals and Sports, respectively. 

When the "Prune VC" command is invoked, the following dialog will appear: 

 

Fig. 2 

In Fig. 2 the two animal folders have been selected and will be included in the pruned VC. Clicking 

"OK" results in the pruned VC shown in FIg.3. Be sure to save the pruned VC with a different name 

than the original catalog. 

In this simple example, it would have been just as easy to simply select the two folders to prune 

(the two "Sports" folders), and delete them in the VC. However, pruning is particularly useful when 

there are many catalog folders to select from. 
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Fig. 3 

  

  

  

 

  

Shortcuts 

Toolbar:       

Keys:          Ctrl+P   

4.5 Virtual Catalog Drive Editor 
If you have moved your folders to a different drive (with a different drive letter or path), then you can 

modify the Virtual Catalog (VC) by using the VC Drive editor available on the Edit menu. Click this 

to open a dialog box where you may select (with the left mouse button) and edit the drives. You 

may also edit path names - up to four levels deep - that will appear on the new drive. 

5. View commands 

5.1 Toolbar 
Use this command to display and hide the Toolbar, which includes buttons for some of the most 

common commands in SewCat, such as File Open. A check mark appears next to the menu item 

when the Toolbar is displayed. 

 

See Toolbar for help on using the toolbar. 

5.2 Large Toolbar Icons 
Click this View menu item to toggle between the small and large main toolbar icons.  

5.3 Status Bar 
Use this command to display and hide the Status Bar, which describes the action to be executed by 

the selected menu item or depressed toolbar button, and keyboard latch state. A check mark 

appears next to the menu item when the Status Bar is displayed. 
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See Status Bar for help on using the status bar. 

5.4 Jump Stitches 
Use this View menu item to toggle on/off jump stitches in the magnified display of the pattern file in 

the lower right (catalog) panel. 

5.5 Texture 
Use this View menu item to toggle on/off a textured display of the selected pattern file in the lower 

right viewing panel. Texturing is automatically off in the middle icon view in order to implement fast 

scrolling. At present, SewCat does not print textured icons (but this may change in the future). 

5.6 Units 
Use this View menu item to toggle between American units (inches) or metric units (mm) for the 

length properties of displayed patterns. 

5.7 Zoom Icons 
Click this View menu item to change the viewable size of the file icons appearing in the central 

panel. Click the "+" glass to magnify the image, and the "-" glass decrease the image size. Resizing 

the file icons can also be accomplished by holding down the Ctrl-key and scrolling the Mouse 

Wheel. 

 

Shortcuts 

 

Toolbar:                   

5.8 Virtual Catalog-Explorer 
Click the Virtual Catalog-Explorer item (on the View menu) to toggle the right panel (catalog) view 

between the Virtual Catalog and the Windows Explorer view.  

 

In the Virtual Catalog View, the right panel displays the user-defined virtual catalog tree structure. 

This structure is called virtual because it does not alter the location of any of the files stored on your 

drive.  

 

In contrast, in the Explorer view the right panel displays the directory tree of your actual physical 

media attached to your computer (hard drives, floppy drives, CDs, USB media, etc.). Now, any 

changes you make in this tree will be permanently stored on your drive. This mode of operation is 

exactly the same as what you would do using the actual Windows Explorer. However, only 

embroidery files are shown in the SewCat Explorer view, simplifying the file management activity.  



SewCat v4.2.2 

 22 

You may drag/drop files from the center icon panel into this Explorer panel, or within the Explorer 

panel.  

 

Helpful hint: Hold down the Ctrl key to copy (not move) files from one place to another in either 

the Virtual Catalog or Explorer Catalog. 

 

 

An explorer-style directory tree will appear in the right panel overwriting the virtual catalog (which is 

stored temporarily in memory - be sure to save it before exiting SewCat). All the embroidery files 

stored on your various drives (floppies, hard drives, CD's, USB media) can now be viewed in the 

Windows Explorer-like right panel. You may drag/drop files from the center icon panel into this 

Explorer panel. Now the files you add will be permanently stored on the physical media (hard, 

floppy or Zip disk) you drop them onto. In contrast to virtual catalogs - which do not modify your 

disk contents - moving files and deleting folders in the Explorer panel will change the files and 

directories on your drive(s). The result is exactly the same as using Windows Explorer to 

rearrange your files and folders. The user should be aware of this important difference between 

the SewCat Virtual Catalog and Windows Explorer functionality. 

5.9 Thumbnails 
Click the Thumbnails item (on the View menu) to toggle the middle-pane view between normal 

(display both folders and file icons) and thumbnail (display only file icons) view. This is useful for 

printing out a catalog of your files. 

5.10 File Information 
Click this View menu item to pop-up a menu for toggling (showing or hiding) the display of certain 

file properties in the central icon panel. Check the File Details item to display the number of stitches 

and colors, together with the pattern size. Check the Color Stops item to display the color stops (up 

to 36 of them) corresponding to the thread in the pattern. 

 

Whatever is checked here will appear both in the icon panel and in the print preview and print 

album screens. 

5.11 Large Catalog Folders 
Click this View menu item to toggle the size of the folder icons displayed in the Virtual Catalog. 

5.12 Uncatalogued Files 
Use this View menu item to show or hide icons in the middle-pane that arise from selecting system 

folders in the left pane of SewCat. If this menu item is unchecked (the default state, see Fig. 1a), 

the icons for previously catalogued files will appear in the center-pane with a dark green check-

mark at the lower right corner. In this example, the first and third files have been catalogued. If this 

menu item is checked, the icons for catalogued files will be hidden (see Fig. 1b). This option is 

inactive (dimmed in the View menu) if the mid-pane icons arise from checked virtual catalog (VC) 
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folders (all file icons will appear with green check marks and the "Uncatalogued files" state is 

ignored). 

 

Checking this item may be useful to print a catalog comprised of only newer files that were added 

to your system since the catalog was originally made. It is also useful for adding these newer files 

to the (virtual) catalog. Note that when this item is checked and the icons populating the mid-pane 

arise from system folders, and a file icon is dragged and dropped into the VC, the file icon will 

immediately appear in the middle pane with a red check mark (see Fig. 1c). This will allow multiple 

drag/drops into the VC. The red check mark is cleared either by toggling this menu item OR by 

toggling a system folder. If, however, the mid-pane is populated by files from VC folders, 

dragging/dropping into the VC will have no effect on the icon display. 

   

 

Fig. 1a  Mid-pane icons displayed with/without check-marks at lower right to indicate their presence 

in V while "Uncatalogued files" is unchecked. 
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Fig. 1b  Mid-pane icons displayed only for files not in the VC. "Uncatalogued files" is checked for 

this case. 

  

  

  

 

Fig. 1c  Mid-pane icons displayed with red check marks for selected files that were 

dragged/dropped into the VC while "Uncatalogued files" is checked. 

5.13 Zip Files 
Use this View menu item to show or hide the display of embroidery files that are compressed in zip 

files. SewCat will scroll faster when compressed files are not viewed. 
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6. Tools commands 

6.1 Alphabetize 
Select this Tools menu item to toggle on/off the automatic alphabetizing of files dropped into the 

SewCat catalog trees. When this feature is on, the next file(s) dropped into a folder will 

automatically alphabetize all the files in that folder.  

 

Also, checking this item at any time will automatically alphabetize the entire Virtual Catalog. 

6.2 Background Color 
Use this Tools menu option to open a pop-up dialog for selecting icon and panel background colors. 

6.3 File Filter 
Use this Tools menu item to open a dialog with a list of allowable embroidery, quilt and image file 

extensions that will be displayed in the middle icon panel. Click Select All if you want to show all file 

types. If you wish to show only several of the allowable file types, select those extensions by using 

the Arrow keys (Up or Down) and pressing the Enter key to select them. Hold down either the 

Shift or the Ctrl key to make multiple selections. The file types not selected will be masked out 

(filtered) and not be displayed in the icon panel (even if files of that type exist in the search 

directories). 
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Fig 1. The dialog for selecting file-type filters to limit searches. 

 

Note: 

The catalog files will be automatically refreshed to reflect the filter changes when you click the "OK" 

button. 

 

Shortcuts 

Toolbar:       

Keys:           

6.4 Hover Delay 
Use this tools menu option to open a dialog for entering the hover delay time. This is the time delay 

between when you drag a file (icon) over an unopened folder and when the folder will automatically 

open (expand) in response to the dragging operation. To avoid opening folders inadvertently as you 

drag files over them, it is advisable to make this delay time greater than about ½ second (enter 0.5 

or larger). 

 

You may also select from two AutoExpand options. This determines when (or if) an unopened folder 

will automatically open. The two choices are: 

 

1. Folder expands if you either drop a file on it or the hover timeout period (set above) is exceeded. 

2. Folder expands only if the hover timeout period si exceeded. 

 

This latter option is useful if you are moving a lot of files and do not care to view the contents of a 

folder at this time. 

6.5 Icon Layout 
Use this tools menu option to open a dialog for entering the number of icon columns (icons per row) 

appearing on the screen. 

6.6 Import Folders 
Use this Tools menu item to add new folders to the Virtual Catalog by importing existing directory 

folders from the left panel (directory) tree. After checking the folders in the left panel that you wish 

to import, click this menu item and the selected folder tree will appear as empty folders in the 

Virtual catalog below (as children of) the presently active (selected) folder in the Virtual catalog. 
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6.7 Search Criteria 
Use this tools menu option to open a dialog for selecting certain criteria to search for files on your 

harddrive (Fig.1a) or in the Virtual Catalog (Figs. 1a-b). 

  

A search can be performed both for the directory folders in the left-pane or the Virtual Catalog 

(VC) folders in the right pane, depending on which pane is currently active. For both panes, there 

are pattern matching criteria (pattern size, number of stitches and colors) and creation date criteria 

than can be set (see Figs. 1 and 2).  

  

Keyword searching is different for the directory and VC panesL:  

  

1.  Directory Pane  

Referring to Fig.1a, you can enter word(s) used to find files in selected folders match at least one 

word in their title (file name). Only files in the selected folders which simultaneously match the title 

search AND the pattern criteria will be displayed in the Icon View (middle) Panel. 

Click the "Save keywords" button to retain keywords in the search lists after you change the folder 

selection in the Virtual Catalog. Otherwise, click the "Clear keywords" to remove all the keywords in 

the search lists when this dialog is opened the next time. 

  

2. Virtual Catalog  

Keywords for individual files in the Virtual Catalog were previously loaded in the "Keywords" list on 

the bottom left of Fig.1b by right-clicking files in the VC. See Add Keywords for a description of this 

process. Keywords "letters", "blue'" and "red" were previously added. Two types of keyword 

searches can be performed (simultaneously). One (an "AND" search) searches for files with ALL 

the keywords shown in the middle box in Fig. 1b. The other searches for files with one or more of 

the keywords in the right-most box in Fig. 1b. To add keywords to these two search lists from the 

left "Keywords" list, double-click (or SHIFT+double-click) the keywords in the "Keywords" list. You 

can delete keywords in the two search-criterion lists at any time by selecting them and pressing the 

"Delete" key. In Fig. 1b, only catalog files with the keyword "letter" AND "blue" OR "red" in their 

titles will be displayed in the middle pane..  

  

The displayed catalog files will be automatically refreshed to reflect the keyword changes when you 

click the "OK" button. 
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Fig. 1.  

  

  

   

Fig. 2.  

 

 

Shortcut 

Toolbar:                
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6.8 Convert DG Catalog 
Use this tools menu option to convert a Designer's Gallery catalog file (*.BL) to a SewCat catalog 

file (*.scc). The conversion takes about 20 s per MB of the original catalog.  

6.9 Language Support 
Use this tools menu option to pop-up a menu for selecting the language to use for the user 

interface in SewCat. 

7. Windows commands 

7.1 Cascade 
Use this command to arrange multiple opened windows in an overlapped fashion.  

7.2 Tile 
Use this command to arrange multiple opened windows in a non-overlapped fashion. 

8. Help commands 

8.1 Help Topics 
Use this Help menu item to open the SewCat help manual to the Getting Started topic. 

8.2 Help Manual 
Use this Help menu item to pop-up a floating dialog displaying a summary of the SewCat user 

manual. This dialog may be moved and resized and can be visible even viewing directory file icons 

in the middle icon panel. 

8.3 Context Help 
Use the Context Help command to obtain help on some portion of SewCat. When you choose the 

Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark. Then 

click somewhere in the SewCat window, such as another Toolbar button. The Help topic will be 

shown for the item you clicked. 

 

Shortcut 

      Toolbar:                    

Keys:                     SHIFT+F1 
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8.4 Auto-Update 
Use this toggle command to allow (prevent) automatic updating of SewCat software. When this 

menu item is checked (unchecked), auto-updating is allowed (prevented). With auto-updating 

allowed, the S & S website will be checked whenever the application is opened (but not more than 

once daily) for available updates. If there is an update available, the user will be given the 

opportunity to install it. The installation will automatically close the SewCat workspace, remove the 

older version, install the update, and restart the application. 

8.5 Update Now 
Use this command to search the S & S website for the availability of an update for SewCat. If an 

update is found, the user is given a choice to install it. 

8.6 Restore Defaults 
 

 Use this command to reset the installation default settings for your copy of SewCat. 

8.7 About SewCat 
Use this command to display the copyright notice, registration and version number of your copy of 

SewCat. 

8.8 Change (History) Log 
Use this command to display a readable text file describing the history of changes made to 

SewCat. 

9. Toolbars 

9.1 Main 
The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar 

provides quick mouse access to many tools used in SewCat, 

 

 

 

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T). 

  

                   Click                   To 
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Open a new document. 

 

Open an existing document. SewCat displays the Open dialog box, in which you can 

locate and open the desired file. 

 

Save the active document or template with its current name.  If you have not named the 

document, SewCat displays the Save As dialog box. 

 

Save-As the active document with a new file name. 

 

Print the active document. 

 

Reverse the last file or folder deletion. 

 

Cut (delete) the selected folders or files. 

 

Insert a folder at the current selection point in the Virtual Catalog. 

 

Add a mask (or filter) to the file search, allowing only specified file types to appear in the 

middle icon-view pane. 

 

Set search criteria based on file names, keywords stored in the Virtual Catalog, or 

pattern-based measures. 

 

Zoom-in (magnify) the size of the icons displayed in the middle pane. 

 

Zoom-out (reduce) the size of the icons displayed in the middle pane. 

 

Open help manual.  

 

Context-sensitive help. Click this and move cursor to toolbar item or menu item for which 

help is required, and click on that item. 

 

9.2 Status bar 
The status bar is displayed at the bottom of the SewCat window.  To display or hide the status bar, 

use the Status Bar command in the View menu. 
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The left area of the status bar describes actions of menu items as you use the arrow keys to 

navigate through menus.  This area similarly shows messages that describe the actions of toolbar 

buttons as you depress them, before releasing them. If after viewing the description of the toolbar 

button command you wish not to execute the command, then release the mouse button while the 

pointer is off the toolbar button. 

 

The remaining areas of the status bar indicate information about the status of the catalog (left 

pane), is described below: 

 

Indicator                      Description 

2nd Pane                      Full path name of the (original) file store in the catalog 

3rd Pane                      Number of embroidery files selected (checked) in the left-pane tree 

Last Pane                     Number of embroidery files in the present catalog 

10. Miscellaneous 

10.1 Add Keyword 
Use the dialog shown below to add keywords to individual catalog items. The dialog appears as a 

pop-up when a file in the Virtual Catalog is right-clicked. It allows you to enter or modify keywords 

for the selected file that will be added to the search keys when a keyword search is performed. 
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Keywords can also be added to multiple selected files at once. 

10.2 Keywords for multiple files 
The dialog below will "pop-up" to allow you to modify a group of selected files in the Virtual Catalog 

(VC). This will allow you to enter Keywords (or Prefices and/or Suffices to the VC file names) for all 

the selected files at once. There are two ways to access this dialog: 

 

1. LEFT-CLICK on the first file in the VC group and then - with the SHIFT (or CTRL) key held 
down - RIGHT-CLICK on the last file in the group you want to modify. 

2. Select the folders containing the files to be modified in the VC so the files appear as icons 
in the mid-pane. Then (SHIFT+/CTRL+) LEFT-CLICK the files in the mid-pane to be 
modified. Holding down the SHIFT or CTRL key, RIGHT-CLICK the last file in the group of 
selected icons in the mid-pane. 

 

 

 

 

 

The first item in the dialog allows you to add keywords to the selected files. 
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There are situations when you might want to add a prefix or suffix to a group of files in the Virtual 

Catalog. For example, you may want to identify the files by the initial of the digitizer by adding 

"_abc" to the file name. The dialog box shown below will appear as a pop-up. For this example, 

enter in the suffix box the desired characters (_abc) and press OK. This suffix will be added to the 

files you selected in the Virtual Catalog (before the file-type extension). 

10.3 Locate file in VC 
Right-click the file icon displayed in the middle panel to find the location(s) of that file in the Virtual 

Catalog (VC). A list of paths will pop-up (see Fig. 1) showing where the file can be found in the VC. 

Note that only files in the mid-pane with check marks are in the VC. You can click on an entry in the 

list to automatically open the VC to the folder containing the file. 

  

  

 

Fig. 1 

10.4 Locate system path 
Left-click the file icon displayed in the Virtual Catalog (VC, right-panel) to find the source location of 

that file on your Hard Drive or CD (or other media). An icon of the file pattern will appear in the 

lower right pane, and the original source path will appear in the  

10.5 Display Icons 
File icons may be displayed in the central (view) panel by selecting folders containing embroidery 

files from either the directory tree in the left (directory) panel or the virtual catalog in the right panel. 

In either directory tree, use the left mouse button to click the "+" appearing to the left of any 

unexpanded directory. This will expand the directory to show any subdirectories. The embroidery 

file icons may be displayed by clicking the checkbox next to each directory. If you click the box 

without expanding the directory, all the files in that directory and its subdirectories will appear (as 

icons) in the center file-icon panel. Clicking again on the check box will remove the associated 

icons from the icon panel. Also, clicking the "-" next to an expanded directory will collapse it. 

 

When you have checked the box of a directory containing embroidery files, images (icons) of the 

patterns contained in those files will appear in the middle (icon view) panel. The file name is 
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shown below each icon. An asterisk after the file name indicates it is contained in a Zip archive. To 

show more details about the files, click the File Details item in the View menu. The displayed size of 

the icons (zoom) can be changed by selecting the Zoom Icons item in the Tools menu or clicking 

the “+” or “-” button on the toolbar. If necessary, a vertical scroll bar will automatically appear on the 

right of the center panel, as well as a horizontal scroll bar at the bottom of the panel. Click the scroll 

bar button to activate scrolling in the central panel. Dragging the scroll bar, or using the Page Up, 

Page Down, Home or End keys, will allow you to view all the icons in the opened folder. 

 

You can filter the files that are displayed in several ways. In the Tools menu, the File Filter item will 

allow you to select only certain embroidery file types (extensions) to be displayed. The Search 

Criteria item allows you to use certain file properties to limit the icon display. For VC icons, 

keywords can also be used to determine which icons are shown. The View menu item 

Uncatalogued Files will allow you to limit the display of files to only those that are not in the present 

catalog.  

10.6 Open File with Editor 
SewCat will allow you to open a file with an associated editor by double-clicking the file icon in 

either the mid-pane (icon view) or the Virtual Catalog (VC). The extension of the file must be 

previously associated with an editor for this to work. 

  

You can also drag and drop an embroidery file icon into an open embroidery file editor.For example, 

suppose your embroidery editor is SewWhat-Pro. By opening both SewWhat-Pro and SewCat 

side-by-side (they will need to be resized so both are visible on the desktop - use the restore button 

at the top right of the application to resize it), you can drag a file from either the Virtual Catalog 

(right panel) or the middle panel in the SewCat workspace and drop it into the SewWhat-Pro 

workspace. If the SewWhat-Pro workspace is empty, this will automatically open a new editing 

pane with the dropped file appearing in it. If there already is a file in the SewWhat-Pro editing pane, 

then the dropped file(s) will be merged with the existing file. This may be used, for example, as an 

easy way to combine alphabetical characters (such as monograms) with pictorial sewing patterns. 

10.7 Move files 
To move files from the central panel into the catalog tree (the right-most panel), you must first 

select the file icons by clicking them with the left mouse button. A selection rectangle will be drawn 

around the icons you select. Hold down the Ctrl or Shift keys to select multiple icons for moving. 

Double-clicking a selected icon, or clicking the left button anywhere outside the selection box 

around the icon, will clear the selection box of all previously selected icons. To clear a single icon, 

hold down the Ctrl key before clicking again. This selection behavior is similar to Windows Explorer. 

 

Once the icon(s) have been selected, hold down the left mouse button (while the mouse cursor is 

over one of the selected icons) and drag the icon(s) into the catalog (right) panel. Drop the icon(s) 

over the catalog folder where you want the associated files to appear. 

 

Be aware that when you are working in Catalog View mode, moving files into the catalog tree does 

NOT actually move files on your hard drive. Rather, a database of file names is created that links 
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the names in the catalog tree to the files on the hard drive. This virtual catalog takes up almost no 

additional disk space and maintains the integrity of your directory structures. Moving, deleting or 

inserting files into the catalog tree has no effect whatever on the files stored on your hard drive. 

However, should you remove or move files on your hard drive after creating a virtual catalog, this 

will cause the catalog links to be unresolved the next time the catalog is opened (that is, the moved 

files will no longer be found).  

 

In Explorer View mode (which should only be used once you have gained some experience with 

the SewCat system), files are actually moved around on your hard drive. No catalog need be saved 

in this case (indeed, you will not be allowed to use the Save options), since the tree structure is 

being permanently recorded on your hard drive. Note that now, deleting files and folders is a 

permanent action, just as though you were working in Windows Explorer. 

10.8 Rename files 
To rename folders or files in the catalog tree (the right-most panel), first select the catalog folder or 

file to rename by clicking it with the left mouse button. Then, either left click the text label to the 

right of the folder (or file) icon, or press the F2 key to highlight the label. Edit the text and press 

either Enter to accept the new text or Esc to restore the original text. 
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